Description

The page details the installation of the NTT MCP Ansible modules and required Python modules.

Installation

Installation of the modules requires a Unix/Linux or Mac system with an Internet connection.

Installing the prerequisite Python modules

pip install --user requests configparser PyOpenSSL netaddr

or for systems with Python3

pip3 install --user requests configparser PyOpenSSL netaddr

Installing the NTT MCP Ansible Collection

ansible-galaxy collection install nttmcp.mcp

Upgrading

From time to time the NTT MCP Ansible modules will be updated to support new features and include bug fixes. The latest version can be viewed on the Ansible Galaxy page for the modules. The latest version can always be installed using the command below:

ansible-galaxy collection install nttmcp.mcp -f

Recently Updated